Jump to content
  • Hawaii Time Pacific Time Mountain Time Central Time* Eastern Time Western European Eastern European Eastern Daylight

    *Official unit time is Central Time. All times posted are in the Unit time unless otherwise indicated.

Stuck on loading screen [SOLVED]


Recommended Posts

DL all mods last night required for the new 15th update. But for some reason  when I try to log into our Rec Server I get stuck on the loading screen after picking my role. I tried even local servers and it would stay stuck on the loading screen to enter the server to play, I read several forums online indicating to load the mods in the correct order? Anyone have any input? Previously I've never had this issue loading into our servers. 


4/5/14 *Solution make sure you run in 32 Bit if your PC cant handle 64. Via Arma 3 Launcher Options. 

Edited by SNA Pacheco
Link to comment
Share on other sites

The Recruiting server uses a different mod set than the standard 15th for the Official Task Force servers. So this means you may have 2 versions of CBA or ACE in your available mods, and you need to load the correct version for Standard 15th vs. 15th Recruiting Server. Confirm that your Recruiting server set is the same as listed below, then try loading in again.


Check this thread for the list and links:


Edited by Sgt Riggenti
  • Like 1
Link to comment
Share on other sites

Thanks Sgt, But I looked at that same list. Im running for Rec Server as follows.


Task Force Radio 1.-1 (dev) (link given from 15th update for TFR)


ST Hud






RHS Gref






Cup terrains core


Cba v3.2.1






Ace 3.9.0

Link to comment
Share on other sites

Load in this order: CBA, TFAR, ACE, RHS, CUP Terrains, maps, client-side mods. (if this doesn't do it swap TFAR and ACE. I can't remember the more reliable method but I think they're interchangeable).


Typically though being stuck on the loading screen is more about network problems than mod problems. Mod problems usually just boot you out.

  • Like 2
Link to comment
Share on other sites

Penny is correct. If your mods aren't lining up with the server, you'll get booted before you get to the slot/affiliation selection screen. If you're getting stuck at a black screen after selecting your slot and clicking join (or whatever the text says) then you are having other issues.  Validate game integrity, try loading into a self-hosted server and see if results are the same.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.