Jump to content
  • Pacific Time Mountain Time Central Time* Eastern Time Western European Eastern European Eastern Daylight
    (GMT -8) (GMT -7) (GMT -6) (GMT -5) (GMT 0) (GMT +1) (GMT +10)

     

    *Official unit time is Central Time. All times posted are in the Unit time unless otherwise indicated.

Arma stuck at low FPS


Recommended Posts

I'm returning to Arma and the 15th after several years away. I have a much stronger PC than I did the last time I was in the 15th (and I played at high/ultra with 30+ FPS) yet now I cannot get Arma to break 13 FPS even on low settings in the editor and no addons. I've tried many optimizations including command line params and my PC isn't even breaking a sweat ( 55% RAM used, 30% CPU steady on all cores, GPU doesn't break 40%, all temps are barely above idle.) All google results I can find usually have an obvious culprit (overheating, parked CPUs, etc.) or literally end with "Well that's just Arma, it doesn't run at high FPS."

 

Here are my specs:

16GB DDR4 Ram

i7-4790 @ 4.00 gHz

Geforce GTX 1060 6gb

Arma on an SSD

 

Anybody have any ideas?

Link to post
Share on other sites

In your launcher parameters make sure the following things are set:

 

Platform: 64bit

CPU Count: 8

Extra Thjreads: All on

Enable Hyper-Threading: On

Memory Allocator: Intel TBB4 (this is the biggest one!)

Enable large-page support: On

System memory limit: Set to 14336 (14gb so your OS can keep the remaining 2)

 

 

Report back if that helped.

  • Like 1
Link to post
Share on other sites
11 hours ago, LCpl Belgrave said:

Well first things first, are your drivers up to date? 

 

Yes, I just updated my Nvidia drivers this week.

10 hours ago, LtCol Saarema said:

In your launcher parameters make sure the following things are set:

 

Platform: 64bit

CPU Count: 8

Extra Thjreads: All on

Enable Hyper-Threading: On

Memory Allocator: Intel TBB4 (this is the biggest one!)

Enable large-page support: On

System memory limit: Set to 14336 (14gb so your OS can keep the remaining 2)

 

 

Report back if that helped.

Good to see you're still around, Saarema! I've tried those settings and I still get 8 FPS on low settings, even on 1080 and 720 resolutions.

 

EDIT: Disregard. I went and changed a few Nvidia Control Panel settings and I guess one of them fixed the issue. I'm now bizarrely able to run 60fps on Ultra. It may have been Vsync: Adaptive>Off, or MSAA: On>Off. It may also have been shutting down my liquid cooler monitor. 

Edited by Cpl Wallace
Link to post
Share on other sites
On 1/13/2021 at 11:47 AM, LtCol Saarema said:

In your launcher parameters make sure the following things are set:

 

Platform: 64bit

CPU Count: 8

Extra Thjreads: All on

Enable Hyper-Threading: On

Memory Allocator: Intel TBB4 (this is the biggest one!)

Enable large-page support: On

System memory limit: Set to 14336 (14gb so your OS can keep the remaining 2)

 

 

Report back if that helped.


Funny enough. I enabled these settings to cause why not but now my arma is constantly crashing when joining servers. 
Are you sure these settings are correct?

Link to post
Share on other sites
39 minutes ago, Maj D. Johansen said:


Funny enough. I enabled these settings to cause why not but now my arma is constantly crashing when joining servers. 
Are you sure these settings are correct?

They look correct to me, did you adjust the memory limit to something that you actually have the memory to support?

Link to post
Share on other sites
8 hours ago, Maj D. Johansen said:


Funny enough. I enabled these settings to cause why not but now my arma is constantly crashing when joining servers. 
Are you sure these settings are correct?

 

These settings are also hardware dependant. So if you're running different hardware than him, no wonder you're crashing.

Post your specifications below and I'll post the correct settings for your setup.

Link to post
Share on other sites
6 hours ago, LtCol Saarema said:

 

These settings are also hardware dependant. So if you're running different hardware than him, no wonder you're crashing.

Post your specifications below and I'll post the correct settings for your setup.


Yeah that would explain a lot lol


Specs

16GB DDR4 Ram

i7-7700k, 4.20 gHz

Geforce RTX 2070 Super 8gb

Link to post
Share on other sites

does it happen on all servers equal ? i had an issue a while back where one of the sights caused my game to freak out and i just needed a change in kit  my second thing would be go check your files an update might have messed with something  also a friend of mine has a simillar set up and only get about 45 avg fps  due to the way towns are done in the game  best way to help with this is slightly lower your video quality   i seen this help in the past on a few accounts 

Link to post
Share on other sites

I think I've figured out the issue:

I have a Tobii Eyetracker that comes with software to integrate it with games that utilize the Tracker, Arma III being one of them (although I don't use it in Arma.) I'm assuming it was conflicting with TrackIR (which I *do* use in Arma) and causing massive drops. It starts automatically with Windows, so I originally fixed my issue by closing it down along with all other non-essential programs. Tonight at the FTX my issue returned since I'd restarted my computer the night before, causing the software to start up again and it caused me to have severe FPS issues and have to run the whole operation at 6 FPS. Closing the Tobii programs and restarting Arma fixed the issue once again.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.